Sign in to follow this  
Followers 0
rob

BV2s helmet: fogging problems? ele shield?

20 posts in this topic

I got a new BV2s helmet in the off season, and I've been trying it out this week. I like the good vision and warm feeling it gives, but I've had some problems getting the mask fitted to my face so as to avoid air leaks and fogging. Today in the afternoon it warmed up, and I found myself sweating a bit, and the shield condensed my breath or sweat and I fogged up terribly. I'm looking for any suggestions or advice. And what about an ele shield? I've seen mixed reports about the ele shield for the BV2s, with many saying they distort and/or fog between the panes. That's why I didn't get one so far. Do I need one? Right now I'm about ready to go back to my TXi helmet, but I want to give the BV2s a fair chance first. :wacko:

Share this post


Link to post
Share on other sites

I can't give you any advice Rob but if you don't mind I'd like to throw in my woes.

My problem is I can't seem to get the mask to seal right and since I wear glasses my glasses fogged :( but the shield stayed nice and clear :). I tried the three hole thingy in the mask since the instructions recommended that for the temps that day. I was a bit heated at that point from unloading the sleds so not sure that was part of the problem. I cracked open teh visor to see if that would help but it did not. I guess I need to try it a little more and see what happens.

I put the electic shield on and it seemed to me no distortion - maybe I need electric glasses :wacko: .

Luckly I brought my HJC I have used and drove back a mile and wore that the rest of the trip.

Edited by ct_skidoo

Share this post


Link to post
Share on other sites

How's the new Doo Rob?

Share this post


Link to post
Share on other sites

This may sound stupid,

have you visited dootalk?

I would think there answer maybe over there, IF there is an answer at all.

Share this post


Link to post
Share on other sites

i have one and there are some things i've learned. the three hole thingy sometimes the rubber doesn't lay flat. it gets bent then it really fogs i always check that now. do you have beard or goat? if you do and its not trimmed sometimes doesn't help also the face piece can go tighter by the other adjustment that you pull before turning and make tighter to your face. good and firm, thats where i go wrong i think its tight but its only snug and when coming to a stop and i'm sweating i just break the seal on the shield and tilt head back a hair. good luck trail an error. :wacko:

Share this post


Link to post
Share on other sites

It's like a Harley, alot of work. :lol:

I think the wife gave mine away or it never returned. Did not miss it.

Share this post


Link to post
Share on other sites

i have the same problems----------it is too hot-------i sweat -it fogs------i thought it was just when it snowed------not the case---does it while riding ''slower''

my next step is a $180 elec shield for it!!! :banghead:

Edited by brian55lvr

Share this post


Link to post
Share on other sites

Rob,

1sledhead2 is correct, I have found that the breathing tubes need to fit exact. What I do is once I am ready to close the front, is to press the buttons that you use to open the front. This way the latches do not pull down on the breathing tubes. I then make sure that when I breath, air is coming out the sides. It sounds like a lot, but it really isn't.

I also find the helmet warm. If the temp allows, I open the shield a little, and it feels nice.

The key is keeping the hoses intact with the sides of the helmet

Share this post


Link to post
Share on other sites
Rob,

1sledhead2 is correct, I have found that the breathing tubes need to fit exact. What I do is once I am ready to close the front, is to press the buttons that you use to open the front. This way the latches do not pull down on the breathing tubes. I then make sure that when I breath, air is coming out the sides. It sounds like a lot, but it really isn't.

I also find the helmet warm. If the temp allows, I open the shield a little, and it feels nice.

The key is keeping the hoses intact with the sides of the helmet

I'm not sure what you mean by the 'hoses'? Could that be the other doo modular helmet? This bv2s just has a mask. And when I tighten the front adjuster knob it sometimes makes it worse, in that tighter seems to make it leak more breath at the bridge of my nose? I get the fogging at top.

How's the new Doo Rob?

Love the new Renegade XP. Very familiar, not that different from the '05 in my opinion, I felt right at home right away. Seating position is just as good, even better in that you can move your feet around more. Sled feels slightly lighter, slightly more nimble. Still pushes a bit under power, (as you would expect on a Renegade chassis). Very stable at speed. :good:

Share this post


Link to post
Share on other sites

inside the mask is 3 diapham valves 2 intake (left-right) and 1 in front is exhaust. if the intake is folded over or bent it blows back into helmet causing condensation and fogging up.i have electric but that only use in ice and snow. you might try to move mask more away from the chin also

Share this post


Link to post
Share on other sites

I'm not sure what you mean by the 'hoses'? Could that be the other doo modular helmet? This bv2s just has a mask. And when I tighten the front adjuster knob it sometimes makes it worse, in that tighter seems to make it leak more breath at the bridge of my nose? I get the fogging at top.

Rob,

That is my bad, yes I was talking about the other Modular, which is the one I have

sorry for the confusion

Share this post


Link to post
Share on other sites

Rob, the biggest issue that will cause fogging is not sealing up the helmet correctly before you even start to ride.

And when you stop lift the shield up right away, more so if you are warm, to let the heat out.

(You may know some of this stuff already but I will mention it anyway)

A friend of mine has had one for 2 years now, and he bought the e shield at the same time and was still having fogging issues.

I rode with him this past weekend. We was getting ready to head out, and I seen how he put his helmet on (Wrong).

He was putting the (Chin gaurd? the material with felcro on each side of it.) over the outside of his coat.

I told him make sure you seal it up 1st, then zip your coat collar after, and dont plug the e shield in and see what happens.

He did not need the e shield the whole weekend, so that was his issue. Not sure how you seal yours up.

Also, the mouth piece, leave it loose until you adjust the position to your face, (The mouth piece has a lot of float adjustment) and then tighten just until it seals, if you over tighten the valves may not seat properly. Also make sure it locks correctly.

To check the seal, hold your hand over the outside exaust and to exhale, you should feel the inner mouth piece expand without air leaking to the inside of the helmet. When you close the shield, use 2 hands, and you will hear it lock in place.

Also give yoursef and extra 1/2 hour to get ready before your buddys do. lol JK

It sounds like a pain in the butt, but once you get familar with it you will be fine.

I hope this info helps you out.

Share this post


Link to post
Share on other sites

After speaking with OVR earlier last week I decided to try the BV2S again. I finally got the mask thing figured out and really like the helmet. My next issue is I put the electric shield on the helmet when I bought it. I did not plug it in yet but right after my first successful ride with the helmet it now has this filmy/cloudy stuff between the two plastic panes but just on one side. It is like it is permanantly 'fogged'. My dealer will swap me a new one but I am wondering if I even need it and just put the shield that came with the helmet back on.

Edited by ct_skidoo

Share this post


Link to post
Share on other sites
After speaking with OVR earlier last week I decided to try the BV2S again. I finally got the mask thing figured out and really like the helmet. My next issue is I put the electric shield on the helmet when I bought it. I did not plug it in yet but right after my first successful ride with the helmet it now has this filmy/cloudy stuff between the two plastic panes but just on one side. It is like it is permanantly 'fogged'. My dealer will swap me a new one but I am wondering if I even need it and just put the shield that came with the helmet back on.

Hi John,

I have been out in -10 degree weather and no fogging or frosting problems.

Get the replacement electric shield from your dealer, but try it with the original shield first and see if it works. If it does, sell the electric one on EBAY. :good:

Mark :drinks:

Share this post


Link to post
Share on other sites

I have to say that I've given up on my BV2s. I just couldn't adjust myself to the mask, and the fogging problems. I intend to sell it on ebay next fall unless someone expresses an interest here before then.

Share this post


Link to post
Share on other sites
Hi John,

I have been out in -10 degree weather and no fogging or frosting problems.

Get the replacement electric shield from your dealer, but try it with the original shield first and see if it works. If it does, sell the electric one on EBAY. :good:

Mark :drinks:

Thanks Mark, I'll give it a try. If it works for you it should for me. Kim will like the eBay part. :clapping:

I have to say that I've given up on my BV2s. I just couldn't adjust myself to the mask, and the fogging problems. I intend to sell it on ebay next fall unless someone expresses an interest here before then.

Rob, not sure if this will help but I found my problem was tightening the mask too much and it was not sealing right. I put the 3 hole valve(?) in and backed off on the pressure. The most pressure is on the bridge of my nose and not so much on my chin and that seemed to do the trick - till the other problem happened. :sad:

Share this post


Link to post
Share on other sites
.............

Rob, not sure if this will help but I found my problem was tightening the mask too much and it was not sealing right. I put the 3 hole valve(?) in and backed off on the pressure. The most pressure is on the bridge of my nose and not so much on my chin and that seemed to do the trick - till the other problem happened. :sad:

You hit the nail on the head John. That is a very good description of how to best adjust the mask. Be sure it is sealed well up on the nose and not too much pressure to distort the mask.

Mark :drinks:

Share this post


Link to post
Share on other sites
After speaking with OVR earlier last week I decided to try the BV2S again. I finally got the mask thing figured out and really like the helmet. My next issue is I put the electric shield on the helmet when I bought it. I did not plug it in yet but right after my first successful ride with the helmet it now has this filmy/cloudy stuff between the two plastic panes but just on one side. It is like it is permanantly 'fogged'. My dealer will swap me a new one but I am wondering if I even need it and just put the shield that came with the helmet back on.

Not sure if I mentioned it before or not, I had bought a e shield a couple of years ago and it had the same problem as you mentioned.

The dealer gave me another one and it had the same issue.

So I tried to clean it (Big mistake) I destroyed it.

After cleaning it, there was a film on the inner part of the shield that started to peal off, then I tried the 3 step polisihing system. (Did not work at all) after I got all the film off, there was cloudy / film as you mentioned between the lenses.

Did I learn my leson :wacko: NOT! After planning more trips to PQ this year, I wanted to have the extra secruity of having the e shield, so I got another one.

I have not tried it yet, Its still in the box.

I have been out in -20 and I have not had an issue with the plain shield.

The thing that worrys me, is getting caught in a snow storm, and then it decides to freeze up on me.

On the other hand, I have seen many e shields crap out and freeze up on other riders, so if my non e shield ever freezes up. ??? no big deal I guess.

Almost 8000 miles on plain shield, and the only problems I had, was when I first started to use the BV2S, and after I figured out the adjustments, it works fine.

Share this post


Link to post
Share on other sites

i find in the cooler weather i flip up the shield every time i stop[immediately]----and left it open for a few feet while taking off-[20-100 feet]------

i fgd the breath was causing fogging while at slower speeds

i tried the three hole valve in the breath inlet and worked great for warmer riding ---above 20 deg [keeps me cooler]

under 0 deg i was fogging on the top of shield [sweat] i couldnt fix that

Share this post


Link to post
Share on other sites

I am going to try the non elec shield. My dealer will give me a new elec shield under warranty but hopefully I won't need to use it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0